Install HiveOS on a USB Drive Using Mac OS X: The commands are wrong on Hive OS' site for Mac OS. And some other important tips.

There are some command differences in the terminal vs what HiveOS has on their page. Surprise.

First, *PLEASE* use my link to sign up for HiveOS https://hiveos.farm?ref=813926 so that I get something for my time. :)

Also, you can give me a follow on my tech/investing YouTube Channel: http://YouTube.com/rcbullock

Other Ways to Support Me: (I was thrilled to get some ETC the other day for example.)

http://paypal.me/beachfitrob 

Coinbase US Dollars address. Yup, they still work: 0xB09E3BadF5D8f758865dAC11e4705ae0C33a65eD

Get Coinbase here: https://www.coinbase.com/join/bulloc_c24 We can debate hot and cold wallets later. Also you can earn free crypto by doing the lessons and holding certain types there.


Disclaimer: I'm doing this and typing it up. If it doesn't work, comment. I respond and fix, that's why you'll use my links and give me a cup of coffee etc. :) Also I'm not responsible for anything. Check my work. Data loss is possible if you don't use the right device number...it's mentioned several times but really very simple.

First, let me say, if you are not comfortable with the Terminal in Mac OS or the command line, there's a program that will do all this: https://www.balena.io/etcher/ 

It was recommended on MacOS Daily here Linky but I like to suffer. ;) I have not used it.

UPDATE: I used it. One good thing is if you put an SSD into a USB external case, Balena Etcher will happily write to it as it sees it as a USB drive of course. Also same thing if you put an mSATA to SATA adapter in it.

Amazon links for those: I Get a few cents if you use the links.

I bought a brand new 60GB mSATA SSD for under $20. https://amzn.to/3ri6kak The 2.5" SSD is about the same, and 60GB is the sweet spot I think.

If you need the mSATA adapter pick any one that's cheap IMHO https://amzn.to/3rfny8e and any USB case if you need that https://amzn.to/3FTkJ0F

1. Download HiveOS first. https://hiveos.farm/install/ (But you probably did this, so...)

2. On that download page, there is a link that tells you the md5 of the file so you are sure the download is not corrupted. https://download.hiveos.farm/VERSIONS.txt

3. Open 'Terminal' on your Mac.

4. Type 'su' , enter your root password, and press enter (so you can write/eject drive).

5. Type md5 -r and then DRAG the .xz HiveOS file into the terminal window and release. It will type the path name etc. for you. 

Example:

MacPro:~ robertbullock$ md5 -r /Volumes/BlackTowerMain/Audio/Audio\ Assets/hiveos-0.6-205-stable@210715.img.xz 

6c4bd36db4e6dee0ad314caebea987cc /Volumes/BlackTowerMain/Audio/Audio Assets/hiveos-0.6-205-stable@210715.img.xz


First line is command, second is output. 6c4bd36db4e6dee0ad314caebea987cc is the hash from https://download.hiveos.farm/VERSIONS.txt Make sure it matches what you downloaded.


6. Plug in your USB. THIS WILL BE ERASED. TOTALLY.


7. In terminal (new window if you like) type 'diskutil list' To see a list of devices. We're looking for the USB thumb drive you're going to make into a boot device for your HiveOS rig.


Mine is an older unraid USB boot thumb drive so it looks like this:


/dev/disk5 (external, physical):

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:     FDisk_partition_scheme                        *8.2 GB     disk5

   1:             Windows_FAT_32 UNRAID                  8.2 GB     disk5s1


Your USB drive will have a different name. Make sure, because (AGAIN) it will be ERASED. In this case, it matches the size and name of what I expect.


The /dev/disk5 is what we are going to unmount. 


Type diskutil unmountDisk /dev/disk5 to unmount it. 


8. Unzip the HiveOS file you downloaded. 'The Unarchiver' for OS X is what I used. (On the App Store at https://apps.apple.com/us/app/the-unarchiver/id425424353?mt=12) Right click the HiveOS file and 'Open with...' The Unarchiver.


9. Now we will write the .img file the Unarchiver spits out.


Type dd if= and then drag the .img file into the terminal window (the path and name populate as above)  then type after the path/file of=/dev/disk5 bs=10m


so it looks like


dd if=/Volumes/256GB\ SSD/Scratch\ Folder/hiveos/hiveos-0.6-205-stable@210715.img of=/dev/disk5 bs=10m


(if means input file, of means output file, bs is blocksize)


FINAL WARNING: This will erase /dev/disk5 (or whatever yours is) so MAKE SURE that YOUR thumb drive is the correct device. It PROBABLY won't be /dev/disk5 (dev means device BTW.)



Notes: Selecting the terminal window while dd is working will give you some stats...it isn't frozen.


Such as: (pressing ctrl-T 3 times)


load: 0.84  cmd: dd 60800 uninterruptible 0.00u 0.14s

2+0 records in

1+0 records out

10485760 bytes transferred in 4.945684 secs (2120184 bytes/sec)

load: 0.77  cmd: dd 60800 uninterruptible 0.00u 0.33s

4+0 records in

3+0 records out

31457280 bytes transferred in 11.526043 secs (2729235 bytes/sec)

load: 0.88  cmd: dd 60800 uninterruptible 0.00u 0.51s

5+0 records in

4+0 records out

41943040 bytes transferred in 15.772785 secs (2659203 bytes/sec)


Walk away. This took a 45 MINUTES for me.


UNVERIFIED: According to https://daoyuan.li/solution-dd-too-slow-on-mac-os-x/ replacing 'disk' in the command with 'rdisk' makes this run 20 times faster. So the command would be 


dd if=/Volumes/256GB\ SSD/Scratch\ Folder/hiveos/hiveos-0.6-205-stable@210715.img of=/dev/rdisk5 bs=10m


Yup, just an added 'r'.


Also: USB3 might be faster but I don't recommend that as those run hot. My Unraid server uses a USB2 drive and they recommend that. It won't change the boot speed of your server much. Plus how often you gonna reboot?


EDIT: I reboot a lot. I moved to using an mSATA SSD on my BTC-S37 boards.


Need a USB 2 Thumb drive because you got rid of the old ones? Recommended (again) for these uses due to less heat/greater reliability. Check prices on Amazon and use my link to support me. ;) 


Also, I presorted this for USB 2 and 8/16GB sizes because why buy more? It'll be worthless in a few years then you can buy a 32GB for the same price.


https://amzn.to/3rZ93ny


Troubleshooting:


If you see "dd: bs: illegal numeric value", the 'M' in bs=10M should be 'm'. I.e. lowercase.




Comments

Popular Posts